Degraded NLX services performance

Incident Report for NLX

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:55 EDT

Monitoring

3:30 AM EST - Customers reported increased error rates when accessing resources in NLX services, including Admin Hub and the NLX Platform console.
4:24 AM EST - We have identified the issue. The root cause of this issue is an impairment of several APIs in the US-EAST-1 Region on AWS.
6:00 AM EST - We are starting to see services recover.
8:40 AM EST - We continue to experience intermittent API error rates.
3:00 PM EST - This incident has been resolved.
Posted Oct 20, 2025 - 04:00 EDT
This incident affected: Platform (Platform - Frontend, Platform - API) and Admin Hub (Admin Hub - Frontend, Admin Hub - API).